# $HOME In A Ramdisk I use $HOME in a ramdisk. The reason is in "RAM Is Good" post. How ever, if you simply change /etc/fstab, it would not work. Here is how I did. I use OpenBSD. In /etc/fstab, `````````````````````````````````````````````````````````````````` #6fa78f0d36cf654b.l /home ffs rw,noatime,nodev,nosuid 1 2 swap /tmp mfs rw,noatime,async,nodev,nosuid,-s=32m 0 0 swap /var/run mfs rw,noatime,async,nodev,nosuid,-s=512k 0 0 swap /var/log mfs rw,noatime,async,nodev,nosuid,-s=64k 0 0 swap /home mfs rw,noatime,async,nodev,nosuid,-s=1.5G 0 0 `````````````````````````````````````````````````````````````````` If you just change the original /home into /home/Data, it would no t work, because the system tries to mount it before the ramdisk. S o I commented out. Since I don't have many RAM now, I use only 1.5 G for the ramdisk. By the way, noatime is good for you, and it will not cause any pro blem if you don't use some particular programs. async can speed up , but it could destroy the structure of a partition. However, if y ou use ramdisks, it will reset at every shutdown. Aggressively use async for only ramdisks. Here is a script which executes at every boot time. I use plan9 rc shell. Use rcctl to make it a service. `````````````````````````````````````````````````````````````````` #!/usr/local/bin/rc HQ = /home/libre data = $HQ/Data doas mkdir -p $data doas mkdir $HQ/^(Downloads .dbus .cache) doas chmod -R a+rwx /home doas chown -R libre /home doas mount -o 'rw,noatime,nodev,nosuid' /dev/sd0l $data /usr/local/bin/rsync -a $data/Config/ $HQ . $HQ/.rcrc `````````````````````````````````````````````````````````````````` It's really simple. But remember that when your computer boots, th ere will be just an empty /home directory. You should make an user directory and a data directory by yourself. If you use $HOME instead of $HQ, $HOME will be /root. After mounti ng $data, copy your configs and load .rcrc (or .kshrc, .bashrc, &c .). You should make a download directory and dbus directory, becau se you can't download files in firefox without them. You should ma ke .cache too, because you can't make files in that directory with out the directory. I wrote it before chmod and chown to avoid a re peat. Without chmod and chown, you can't use the directories, beca use of their permisions.